
For teams accountable for public-key infrastructure, web workloads and connected equipment, the closing days of October 2026 delivered two hard lessons in a single news cycle. Two disclosures, published between 17 and 21 October 2026, showed how quickly certificate trust can erode when a key-generation process misbehaves, and how far a defect inside the PHP interpreter reaches into everything stacked on top of it. The first concerned Eight intermediate certificate authority keys belonging to eMudhra that proved easily recoverable; the second concerned memory-safety flaws that could let attackers run code on web servers without authentication. Browser vendors had already moved against the compromised certificates before many operators finished reading the advisories, and that gap between vendor response and estate-wide exposure is the practical subject of this guide.
eMudhra, an India-based certificate authority, created intermediates whose elliptic-curve private keys carried almost no entropy. On paper the certificates used the NIST P-384 algorithm; in practice the private keys were integers smaller than 256 instead of cryptographically random values drawn from the algorithm's far larger key space. The mismatch is the core lesson for anyone who validates cryptographic parameters by label rather than by measurement.
Six of the affected intermediates were intended for Transport Layer Security (TLS) certificates, and two were used for code signing. Anyone who recovered the keys could potentially issue fraudulent certificates for websites or software, enabling impersonation or man-in-the-middle attacks against clients that continued to trust them.
A researcher identified as Wayne reported the problem on 17 October. According to Mozilla's incident investigation, the compromised keys originated from a certificate-generation operation conducted on 30 April 2025, and Mozilla independently recovered the private keys shortly after receiving the report. eMudhra linked the problem to an error involving a script used during key generation, adding that the affected intermediates had seen little or no production use and that no malicious exploitation has been confirmed.
Google Chrome and Mozilla Firefox blocked the affected certificates on 17 October using remotely distributed certificate-revocation mechanisms; Apple and Microsoft later implemented protections. That sequence covers a large share of interactive browsing traffic — and very little else.
Operating systems, command-line utilities, containers and embedded devices frequently rely on certificate stores updated less regularly, and some fail to check whether an intermediate certificate has been revoked at all. Those clients can remain vulnerable despite the browsers' response, which is why a browser-only remediation report usually overstates coverage.
Google has additionally announced plans to remove the emSign ECC Root CA – G3 certificate from its root store, with deployment to affected devices expected from 27 October. Legitimate certificates relying on that root are affected too, so some website operators must replace their certificates rather than wait for a failing handshake.
| Layer in your estate | What the disclosures change | Owner action |
|---|---|---|
| Interactive browsers | Google Chrome and Mozilla Firefox acted on 17 October; Apple and Microsoft protections followed | Confirm the fleet actually received the remotely distributed revocation data |
| Operating system stores, command-line utilities, containers | Refreshed less regularly; some do not evaluate intermediate revocation | Update stores and document the refresh cadence per image |
| Embedded devices | May stay exposed until suppliers ship updated trust stores | Track vendor release notes instead of only internal tickets |
| Sites chaining to emSign ECC Root CA – G3 | Google root store removal deploying from 27 October | Plan re-issuance ahead of rollout to visitors |
The second incident, a collection of memory-safety vulnerabilities in the PHP interpreter tracked as PHP2Shell, is catalogued as CVE-2026-109618 and CVE-2026-109619, with a maximum reported CVSS severity score of 9.2.
Researchers at Wiz and Calif, working alongside OpenAI and the PHP security team, identified weaknesses in how PHP handles memory when requests terminate abnormally. The resulting corruption can allow attackers to access sensitive process memory or execute arbitrary code remotely.
In its technical analysis, Wiz demonstrated unauthenticated remote-code-execution attacks against WordPress, Drupal and Joomla installations. Because the vulnerabilities reside in PHP itself rather than in those applications, other PHP-based services may share the exposure, so a CMS inventory is not a sufficient scope for this work.
The researchers report that AI tools substantially reduced the effort required to construct and adapt complex exploit chains. For defenders the consequence is timing: previously difficult memory-corruption vulnerabilities become more practical to exploit, and the window between disclosure and commodity abuse shortens.
After information about the vulnerabilities circulated ahead of the planned disclosure, the PHP development team published emergency security releases on 21 October. Its security advisory identifies PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35 as patched releases. Versions 8.1 and earlier are no longer maintained by the PHP project, although some vendors provide backported security fixes.
Apache deployments using mod_php are considered particularly exposed, because some demonstrated attacks can be triggered before application code executes. PHP-FPM and other PHP server configurations are also affected, and the PHP security team states that configuration-based mitigations cannot provide complete protection.
The certificate incident is only half of the disclosure window. The PHP2Shell memory-safety flaws, CVE-2026-109618 and CVE-2026-109619, affect the interpreter rather than a specific brand of site, so any PHP runtime in your estate still needs version verification against the advisory releases.
The PHP development team advisory names 8.5.12, 8.4.27, 8.3.36 and 8.2.35 as patched. Versions 8.1 and earlier are no longer maintained by the PHP project, although some vendors supply backported security fixes.
No. PHP-FPM and other PHP server configurations are also affected, and the PHP security team states that configuration-based mitigations cannot provide complete protection. Patching is the control; configuration is supplementary.
Google plans to remove emSign ECC Root CA – G3 from its root store, with deployment to affected devices expected from 27 October. Certificates that legitimately chain to that root lose their anchor there, so operators must replace them instead of waiting for user-visible failures.
No malicious exploitation has been confirmed, and eMudhra said the affected intermediates had seen little or no production use. The risk statement is about capability: anyone who recovered a key could potentially issue fraudulent certificates for websites or software.
Both incidents end on the same operational question: how long does a vulnerability survive in your estate after maintainers publish a fix? Trust stores and third-party software dependencies commonly stay exposed well past that moment, which is why the reportage on connected-equipment suppliers matters as much as the advisories themselves. As previously examined by eeNews Europe in its coverage of the Cyber Resilience Act, keeping a product patched across its supported lifetime is becoming an explicit obligation for European manufacturers. Read against the events of 17 and 21 October 2026, the takeaway for security and IT teams is concrete — find your oldest runtime and your slowest trust store first, then treat both as measured, auditable risk.